Задание №6 ОГЭ по информатике: разбор и шаблоны решений | СмартКИМ
СмартКИМ УДОБНАЯ ПОДГОТОВКА К ЕГЭ И ОГЭ
Все разборы Решать в тренажере Войти в СмартКИМ
ЕГЭ (1–27) ОГЭ (1–15) Python: шпаргалка
Быстрый переход по номерам и темам
Базовый (1 балл) Время: 2-3 мин Python Условный оператор if

Задание №6 ОГЭ. Программа с условным оператором

Тема: Анализ условий if (s > A or t > B) для пар чисел (s, t)
Программа получает на вход пару чисел (s, t). Было проведено 9 запусков с заданными парами. Требуется посчитать, сколько раз программа выведет «YES» (или «NO»), либо найти параметр A.

1. Логика условий if в Задании №6

  • if s > 10 or t > 10: — выведет «YES», если хотя бы одно из чисел строго больше 10.
  • if s > 10 and t > 10: — выведет «YES» ТОЛЬКО тогда, когда оба числа одновременно больше 10.
  • if s // 2 == t: — целочисленное деление первого числа на 2 равно второму числу.

Разновидности и прототипы задания на экзамене

1. Подсчет количества запусков с ответом YES / NO
Проверка 9 заданных пар чисел через связки and / or.
2. Поиск параметра A при заданном числе запусков YES
Определение граничного значения параметра A.

Боевой шаблон решения на Python

Запустить код в онлайн-песочнице
Боевой шаблон решения на Python
# === Боевой шаблон решения Задания №6 ОГЭ на Python ===

# 9 пар чисел из условия задачи:
runs = [
    (1, 2), (11, 2), (1, 12), (11, 12),
    (-11, -12), (-11, 12), (-10, 10), (10, 5), (10, 11)
]

count_yes = 0
count_no = 0

for s, t in runs:
    # Вставьте условие из текста задачи:
    if s > 10 or t > 10:
        count_yes += 1
    else:
        count_no += 1

print("Количество YES:", count_yes)
print("Количество NO:", count_no)

Типичные ошибки

✕ Не так
Ошибка: Перепутать or (ИЛИ) и and (И)
При 'or' достаточно выполнения хотя бы одного условия, а не обоих сразу!
✓ Так
Правильно: Внимательно проверять условие: or = хотя бы одно, and = оба вместе.
ГРОБ

ЛОВУШКА ОГЭ №6: Отрицательные числа и строгое неравенство

Пара (-10, 10) при условии s >= -10 and t < 10.

Как обойти
Внимательно смотрите на знаки строгих неравенств: -10 >= -10 — это True, а 10 < 10 — это False.

Лайфхаки на экзамене

  1. Скопируйте все 9 пар прямо в список кортежей в песочнице Python — ответ будет получен за 10 секунд без ручных вычислений в уме!
Все разборы заданий Открыть в тренажере СмартКИМ