Задание №14 ЕГЭ: Позиционные системы счисления (ID 9139) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №14 Вариант ЕГЭ Разбор в СмартКИМ

Задание №14: Позиционные системы счисления

Задача #9139 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №14:
Позиционные уравнения с неизвестной цифрой x Значения арифметических выражений Перевод между системами счисления

Условие задания

(Апробация-2026) Значение арифметического выражения 9·11210 + 8·11150 − x, где х – целое положительное число, не превышающее 3000, записали в 11-ричной системе счисления. Определите наибольшее значение х, при котором в 11-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 60 нулей. В ответе запишите число в десятичной системе счисления.
Ответ: 2992

Общий шаблон задания №14 на Python

# === Задание 14: Системы счисления и алгебра логики ===
for x in '0123456789ABCDEF':
    num1 = int(f'123{x}5', 16)
    num2 = int(f'67{x}89', 16)
    if (num1 + num2) % 14 == 0:
        print(f"x={x}, Частное от деления = {(num1 + num2) // 14}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №14.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.