Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 8884) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #8884 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

На вход алгоритма подается натуральное число N. Алгоритм строит по нему новое число R следующим образом:
1. Строится семеричная запись числа N.
2. Далее эта запись обрабатывается по следующему правилу:
    а) вычисляется произведение P ненулевых цифр этой записи;
    б) вычисляется сумма S наибольшей и наименьшей цифр этой записи;
    в) значения P и S записываются в семеричной системе счисления в порядке неубывания.
Полученная таким образом запись является семеричной записью искомого числа R. Например, для исходного числа 123 = 2347 получаем P = 2·3·4 = 24 = 337 и S = 2 + 4 = 6 = 67. Тогда результатом является число 6337 = 318. Укажите наименьшее число N, при обработке которого результатом будет число 2725.
Ответ: 3625

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.