Задание №2 ЕГЭ: Таблицы истинности логических функций (ID 8491) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №2 Вариант ЕГЭ Разбор в СмартКИМ

Задание №2: Таблицы истинности логических функций

Задача #8491 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №2:
Построение таблицы истинности Частично заполненные фрагменты Сопоставление строк и столбцов

Условие задания

(Демо-2026) Логическая функция F задаётся выражением (x ∨ y) ∧ ¬(y ≡ z) ∧ ¬w. На рисунке приведён частично заполненный фрагмент таблицы истинности функции F, содержащий неповторяющиеся строки. Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных x, y, z, w.
В ответе напишите буквы x, y, z, w в том порядке, в котором идут соответствующие им столбцы. Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.
Ответ: zyxw

Решение на Python: Печатаем строки, где F = 1

print("x y z w")
for x in 0, 1:
    for y in 0, 1:
        for z in 0, 1:
            for w in 0, 1:
                if (x or y) and (y != z) and (not w):
                    print(x, y, z, w)

Этот код разобран по шагам в разборе задания №2: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.