Задание №8 ЕГЭ: Комбинаторика и подсчёт вариантов слов (ID 8222) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №8 Вариант ЕГЭ Разбор в СмартКИМ

Задание №8: Комбинаторика и подсчёт вариантов слов

Задача #8222 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №8:
Слова с фиксированным алфавитом Слова в алфавитном порядке Ограничения на гласные/согласные

Условие задания

(О. Лысенков) Робот перебирает в порядке возрастания числа, девятеричная запись которых состоит из 6 цифр. Ниже приведено начало списка.
1. 100000
2. 100001
3. 100002
4. 100003
5. 100004
...
Найдите последнее число из списка, в котором никакие две нечётные цифры не стоят рядом, а номер числа оканчивается на цифру 5. В ответе запишите это число в девятеричной системе счисления.
Ответ: 888881

Общий шаблон задания №8 на Python

# === Задание 8: Комбинаторика и списки слов ===
from itertools import product

words = [''.join(p) for p in product('АПРЕЛЬ', repeat=5)]
words.sort()

count = 0
for idx, w in enumerate(words, start=1):
    # Условие из задачи:
    if w.count('Ь') <= 1 and not ('А' in w and 'Е' in w):
        count += 1
print("Подходящих слов:", count)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №8.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.