Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 8214) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #8214 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(О. Лысенков) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.
1. Строится семеричная запись числа N.
2. Далее эта запись обрабатывается по следующему правилу:
  а) если семеричная запись оканчивается на 2, то все тройки в записи меняются на единицы, а все единицы меняются на тройки, а затем к числу слева приписывается 21;
  б) если семеричная запись оканчивается не на 2, то к записи справа приписывается 31, а затем старший и младший разряды полученной записи меняются на 1 и 6 соответственно.
Полученная таким образом запись является семеричной записью искомого числа R. Укажите минимальное число N, для которого результатом работы алгоритма является наибольшее число R, меньшее 744. В ответе это число запишите в десятичной системе счисления.
Ответ: 13

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.