Задание №8 ЕГЭ: Комбинаторика и подсчёт вариантов слов (ID 8143) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №8 Вариант ЕГЭ Разбор в СмартКИМ

Задание №8: Комбинаторика и подсчёт вариантов слов

Задача #8143 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №8:
Слова с фиксированным алфавитом Слова в алфавитном порядке Ограничения на гласные/согласные

Условие задания

(Апробация-2025) Игорь составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Игорь использует 6-буквенные слова, в которых могут быть только буквы М, А, С, Л, О, причём буква С встречается ровно 1 раз. Слово не должно начинаться с гласной буквы и оканчиваться согласной. Сколько различных кодовых слов может использовать Игорь?
Ответ: 1536

Решение на Python: Сколько слов подходит под условие

from itertools import product

k = 0
for p in product("МАСЛО", repeat=6):
    s = "".join(p)
    if s.count("С") == 1 and s[0] not in "АО" and s[-1] in "АО":
        k += 1
print(k)

Этот код разобран по шагам в разборе задания №8: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.