Задание №14 ЕГЭ: Позиционные системы счисления (ID 8052) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №14 Вариант ЕГЭ Разбор в СмартКИМ

Задание №14: Позиционные системы счисления

Задача #8052 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №14:
Позиционные уравнения с неизвестной цифрой x Значения арифметических выражений Перевод между системами счисления

Условие задания

*(А. Богданов) Арифметическое выражение
  SIRIUSp + LYCEUMq  
содержит числа, записанные в системах счисления с основаниями р и q. Заглавные латинские буквы от A до Z обозначают цифры со значениями от 10 до 35 соответственно. Найдите минимальную сумму p+q, при которых значение этого выражения кратно 2025. Запишите в ответе частное от деления значения этого выражения на 2025 в десятичной системе счисления. Примечание: значения p и q могут быть больше, чем 36.
Ответ: 2009655

Общий шаблон задания №14 на Python

# === Задание 14: Системы счисления и алгебра логики ===
for x in '0123456789ABCDEF':
    num1 = int(f'123{x}5', 16)
    num2 = int(f'67{x}89', 16)
    if (num1 + num2) % 14 == 0:
        print(f"x={x}, Частное от деления = {(num1 + num2) // 14}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №14.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.