Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 8032) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #8032 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(О. Лысенков) На вход алгоритма подаётся неотрицательное число N. Алгоритм строит по нему новое число R следующим образом.
1) Число переводится в четверичную систему счисления.
2) Полученная запись преобразуется по следующему алгоритму:
  а) если число чётное, то слева дописывается 12, а справа – утроенное значение младшего разряда четверичной записи в четверичной системе счисления;
  б) если число нечётное, то слева дописывается 13, а справа – 21.
Полученная таким образом запись является четверичной записью искомого числа R. Укажите минимальное значение большее 50, которое может являться результатом работы автомата.
Ответ: 96

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.