Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 7667) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #7667 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

*(П. Финкель) На вход алгоритма подаётся шестизначное натуральное число N. Алгоритм строит по нему новое число R следующим образом:
1. Число N переводится в систему счисления с основанием 19.
2. Далее эта запись обрабатывается по следующему правилу:
  а) согласные буквы (В, C, D, F, G, H) заменяются на 5;
  б) в начало полученной записи дописывается остаток от деления числа N на 19 в 19-ричной системе счисления;
  в) две последние цифры записи переставляются в начало (например, из строки 12345 получается 45123).
3. Действия а)-в) в п. 2. повторяются еще раз.
Полученная таким образом запись записью искомого числа R в системе счисления с основанием 19. Укажите максимальное число R с суммой цифр, кратной 7, которое может быть получено в результате работы алгоритма. Запишите его в ответе в десятичной системе счисления.
Ответ: 893871724

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.