Задание №14 ЕГЭ: Позиционные системы счисления (ID 7631) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №14 Вариант ЕГЭ Разбор в СмартКИМ

Задание №14: Позиционные системы счисления

Задача #7631 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №14:
Позиционные уравнения с неизвестной цифрой x Значения арифметических выражений Перевод между системами счисления

Условие задания

(Демо-2025) Операнды арифметического выражения записаны в системе счисления с основание 19:
  98897x2119 + 2x92319 . 
В записи чисел переменная x обозначает некоторую ненулевую цифру из алфавита 19-ричной системы счисления. Определите наибольшее значение x, при котором значение данного арифметического выражения кратно 18. Для найденного x вычислите частное от деления данного арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления.
Ответ: 469034148

Решение на Python: Ищем наибольшее x и частное

digits = "0123456789ABCDEFGHI"

for x in range(1, 19):
    a = int("98897" + digits[x] + "21", 19)
    b = int("2" + digits[x] + "923", 19)
    total = a + b
    if total % 18 == 0:
        answer = total // 18

print(answer)

Этот код разобран по шагам в разборе задания №14: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.