Задание №8 ЕГЭ: Комбинаторика и подсчёт вариантов слов (ID 7517) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №8 Вариант ЕГЭ Разбор в СмартКИМ

Задание №8: Комбинаторика и подсчёт вариантов слов

Задача #7517 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №8:
Слова с фиксированным алфавитом Слова в алфавитном порядке Ограничения на гласные/согласные

Условие задания

(ЕГЭ-2024) Все пятибуквенные слова, составленные из букв Ф, О, К, У, С записаны в алфавитном порядке и пронумерованы. Вот начало списка:
1. ККККК
2. ККККО
3. ККККС
4. ККККУ
5. ККККФ
...
Под каким номером в списке идёт последнее слово, которое не содержит букв Ф и содержит ровно две буквы У?
Ответ: 2313

Решение на Python: Под каким номером слово стоит в списке «как в словаре»

from itertools import product

alf = sorted("ФОКУС")
n = 0
for p in product(alf, repeat=5):
    n += 1
    s = "".join(p)
    if "Ф" not in s and s.count("У") == 2:
        last = n
print(last)

Этот код разобран по шагам в разборе задания №8: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.