Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 7405) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #7405 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(А. Минак) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.
1. Строится запись числа N в тринадцатеричной системе счисления.
2. Далее эта запись обрабатывается по следующему правилу:
  а) складываются числовые значения всех цифр этой тринадцатеричной записи, и остаток от деления этой суммы на 13 в тринадцатеричной системе счисления дописывается в конец числа (справа);
  б) над этой записью производятся те же действия – справа дописывается остаток от деления суммы числовых значений её цифр на 13.
Полученная таким образом запись является тринадцатеричной записью искомого числа R. Например, для исходного числа 77 = 5C13 результатом является число 5C4813 = 13073. Укажите число N, после обработки которого с помощью этого алгоритма получается наибольшее число R, меньшее 6000.
Ответ: 34

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.