Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 7054) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #7054 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(PRO100-ЕГЭ) На вход алгоритма подаётся натуральное число N. Алгоритм строит по нему новое число R следующим образом.
1. Строится шестеричная запись числа N.
2. Далее эта запись обрабатывается по следующему правилу:
  а) если число N делится на 3, то к этой записи дописываются две первые шестеричные цифры;
  б) если число N на 3 не делится, то остаток от деления на 3 умножается на 10, переводится в шестеричную запись и дописывается в конец числа.
Полученная таким образом запись является шестеричной записью искомого числа R.
Пример. Число 1110 = 156 не делится на 3, поэтому в конец его шестеричной записи 156 дописывается шестеричная запись числа (11 mod 6) · 10 = 20 = 326, так что результатом работы автомата является число 15326 = 41610. Исходное число 1210 = 206 делится на 3, поэтому в конец шестеричной записи 206 дописываются её две первых цифры 20, так что результатом работы автомата является число 20206 = 44410.
Укажите минимальное число R, большее 680, которое может быть получено с помощью описанного алгоритма. В ответе запишите это число в десятичной системе счисления.
Ответ: 694

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.