Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 6887) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #6887 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(Н. Сафронов) Алгоритм получает на вход натуральное число N > 10 и строит по нему новое число R следующим образом:
1. Строится троичная запись числа N.
2. К этой записи дописываются разряды по следующему правилу. Если количество четных цифр в полученной записи больше чем нечетных, слева дописывается 22, иначе 11.
3. Полученная таким образом запись является троичной записью искомого числа R.
Например, для числа 18 троичная запись 2003 преобразуется в запись 222003 = 234, для числа 22 троичная запись 2113 преобразуется в 112113 = 130.
Укажите минимальное значение R, больше чем 100, которое может получится в результате работы алгоритма. В ответе запишите это число в десятичной системе счисления.
Ответ: 120

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.