Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 6861) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #6861 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

*(В. Шубинкин) Алгоритм получает на вход натуральное число N и строит по нему новое число R следующим образом:
1. Строится запись числа N в системе счисления с основанием 45.
2. Цифры числа нумеруются слева направо, начиная с единицы. Отдельно складываются цифры, стоящие на чётных местах, и цифры, стоящие на нечётных местах.
3. Запись меньшей из сумм в системе счисления с основанием 45 приписывается в начало числа, запись большей из сумм в системе счисления с основанием 45 – в конец. В случае появления ведущего нуля, он игнорируется.
Результат переводится в десятичную систему счисления.
Пример. Алгоритм получает число N = 9510 = 2545. Цифра 2 стоит на позиции № 1, цифра 5 – на позиции № 2. Сумма цифр на чётных местах равна 545, сумма цифр на нечётных местах равна 245.
Приписывая цифры, получаем число 225545 = 18653010.
Какое наименьшее число может получиться в результате работы алгоритма при вводе N > 1000? В ответе запишите это число в десятичной системе счисления.
Ответ: 46598

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.