Задание №15 ЕГЭ: Истинность логических выражений на отрезках и множествах (ID 6471) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №15 Вариант ЕГЭ Разбор в СмартКИМ

Задание №15: Истинность логических выражений на отрезках и множествах

Задача #6471 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №15:
Числовые отрезки Множества натуральных чисел Поразрядная конъюнкция (&) Делимость (ДЕЛ)

Условие задания

На числовой прямой даны три отрезка: P = [13; 21], Q = [17; 30] и R = [24; 38]. Укажите наименьшую возможную длину такого отрезка A, что формула

(¬((x ∈ Q) → ((x ∈ P) ∨ (x ∈ R)))) → (¬(x ∈ A) → ¬(x ∈ Q))


тождественно истинна, то есть принимает значение 1 при любом значении переменной х?
Ответ: 3

Общий шаблон задания №15 на Python

# === Задание 15: Истинность логического выражения (Отрезки / Множества) ===
for a in range(1, 1000):
    ok = True
    for x in range(1, 1000):
        # Подставьте формулу из условия:
        f = ((x % 3 == 0) <= (x % 5 != 0)) or (x + a >= 90)
        if not f:
            ok = False
            break
    if ok:
        print("Минимальное значение A:", a)
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №15.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.