Задание №14 ЕГЭ: Позиционные системы счисления (ID 6185) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №14 Вариант ЕГЭ Разбор в СмартКИМ

Задание №14: Позиционные системы счисления

Задача #6185 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №14:
Позиционные уравнения с неизвестной цифрой x Значения арифметических выражений Перевод между системами счисления

Условие задания

(Р. Сорокин) Дано арифметическое выражение:
    179x932 + 7x93128  
В записи чисел переменной x обозначена одинаковая неизвестная допустимая цифра из алфавита вышеназванных систем счисления. Найдите такое число x, такое, что четверичная запись значения данного арифметического выражения содержит наибольшее количество нулей. В качестве ответа запишите сумму цифр четверичной записи числа с наибольшим количеством нулей.
Ответ: 17

Общий шаблон задания №14 на Python

# === Задание 14: Системы счисления и алгебра логики ===
for x in '0123456789ABCDEF':
    num1 = int(f'123{x}5', 16)
    num2 = int(f'67{x}89', 16)
    if (num1 + num2) % 14 == 0:
        print(f"x={x}, Частное от деления = {(num1 + num2) // 14}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №14.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.