Задание №14 ЕГЭ: Позиционные системы счисления (ID 6181) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №14 Вариант ЕГЭ Разбор в СмартКИМ

Задание №14: Позиционные системы счисления

Задача #6181 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №14:
Позиционные уравнения с неизвестной цифрой x Значения арифметических выражений Перевод между системами счисления

Условие задания

(О. Миндзаев) Дано арифметическое выражение:
    1xyx595 + 6yx1795  
В записи чисел переменными x и y обозначены неизвестные цифры из алфавита 95-ричной системы счисления. Определите значения x, y, при которых значение данного арифметического выражения кратно 4221. Для найденных значений x, y вычислите частное от деления значения арифметического выражения на 4221 и укажите его в ответе в шестнадцатеричной системе счисления. Если можно выбрать x, y не единственным образом, возьмите ту пару, в которой значение x меньше. Основание системы счисления в ответе указывать не нужно.
Ответ: 23084

Общий шаблон задания №14 на Python

# === Задание 14: Системы счисления и алгебра логики ===
for x in '0123456789ABCDEF':
    num1 = int(f'123{x}5', 16)
    num2 = int(f'67{x}89', 16)
    if (num1 + num2) % 14 == 0:
        print(f"x={x}, Частное от деления = {(num1 + num2) // 14}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №14.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.