Задание №8 ЕГЭ: Комбинаторика и подсчёт вариантов слов (ID 5760) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №8 Вариант ЕГЭ Разбор в СмартКИМ

Задание №8: Комбинаторика и подсчёт вариантов слов

Задача #5760 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №8:
Слова с фиксированным алфавитом Слова в алфавитном порядке Ограничения на гласные/согласные

Условие задания

*(Д. Статный) Григорий придумывает 16-буквенные слова, состоящие из букв слова АНТИУТОПИЯ. Сколько различных слов, содержащих комбинацию АНТИУТОПИЯ, может составить Григорий, если количество гласных справа от этой комбинации отличается от количества гласных слева на 1? Буквы в словах могут повторяться любое количество раз или же не встречаться вовсе.
Ответ: 418530

Общий шаблон задания №8 на Python

# === Задание 8: Комбинаторика и списки слов ===
from itertools import product

words = [''.join(p) for p in product('АПРЕЛЬ', repeat=5)]
words.sort()

count = 0
for idx, w in enumerate(words, start=1):
    # Условие из задачи:
    if w.count('Ь') <= 1 and not ('А' in w and 'Е' in w):
        count += 1
print("Подходящих слов:", count)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №8.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.