Задание №15 ЕГЭ: Истинность логических выражений на отрезках и множествах (ID 5356) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №15 Вариант ЕГЭ Разбор в СмартКИМ

Задание №15: Истинность логических выражений на отрезках и множествах

Задача #5356 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №15:
Числовые отрезки Множества натуральных чисел Поразрядная конъюнкция (&) Делимость (ДЕЛ)

Условие задания

(ЕГЭ-2022) Для какого наибольшего целого неотрицательного A выражение

(x + y ≤ 22) ∨ (y ≤ x – 6) ∨ (y ≥ A)

тождественно истинно, т.е. принимает значение 1 при любых целых неотрицательных x и y?
Ответ: 9

Общий шаблон задания №15 на Python

# === Задание 15: Истинность логического выражения (Отрезки / Множества) ===
for a in range(1, 1000):
    ok = True
    for x in range(1, 1000):
        # Подставьте формулу из условия:
        f = ((x % 3 == 0) <= (x % 5 != 0)) or (x + a >= 90)
        if not f:
            ok = False
            break
    if ok:
        print("Минимальное значение A:", a)
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №15.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.