Задание №2 ЕГЭ: Таблицы истинности логических функций (ID 3973) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №2 Вариант ЕГЭ Разбор в СмартКИМ

Задание №2: Таблицы истинности логических функций

Задача #3973 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №2:
Построение таблицы истинности Частично заполненные фрагменты Сопоставление строк и столбцов

Условие задания

(В.Н. Шубинкин) Логическая функция F задаётся выражением (x ≡ y) → (z ≡ w). Ниже приведён частично заполненный фрагмент таблицы истинности этой функции, содержащий неповторяющиеся строки. Сколькими способами можно поставить в соответствие переменные w, x, y, z столбцам таблицы истинности функции F, опираясь на информацию из данного фрагмента?
Пример. Функция F задана выражением x ∨ y ∨ z, а фрагмент таблицы истинности имеет вид:
В этом случае переменные можно расставить любым способом, значит, ответом будет число 6.
Ответ: 12

Общий шаблон задания №2 на Python

# === Задание 2: Таблица истинности логической функции ===
from itertools import product, permutations

def f(x, y, z, w):
    # Подставьте формулу из условия задания:
    return (not(x <= y)) or (y == z) or not(w)

for a1, a2, a3, a4 in product([0, 1], repeat=4):
    table = [
        (a1, 0, 0, 1),
        (0, a2, 1, 0),
        (1, 0, a3, a4)
    ]
    if len(set(table)) == len(table):
        for p in permutations('xyzw'):
            if all(f(**dict(zip(p, row))) == 0 for row in table):
                print("Порядок переменных:", ''.join(p))

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №2.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.