Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 2776) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #2776 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(А. Богданов) Автомат обрабатывает натуральное число N по следующему алгоритму:
1) Строится двоичная запись числа N.
2) Все кроме первой значащие цифры инвертируются (0 заменяется на 1, а 1 на 0).
3) Полученное число переводится в десятичную запись.
4) Новое число складывается с исходным, полученная сумма выводится на экран.
Пример. Дано число N = 13. Алгоритм работает следующим образом.
1) Двоичная запись числа N: 13 = 11012
2) Все кроме первой значащие цифры инвертируются: 10102.
3) Десятичное значение полученного числа 10.
4) На экран выводится число 13 + 10 = 23.
Укажите такое наибольшее число N, для которого результат работы алгоритма не превышает 123?
Ответ: 63

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.