Задание №15 ЕГЭ: Истинность логических выражений на отрезках и множествах (ID 22) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №15 Вариант ЕГЭ Разбор в СмартКИМ

Задание №15: Истинность логических выражений на отрезках и множествах

Задача #22 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №15:
Числовые отрезки Множества натуральных чисел Поразрядная конъюнкция (&) Делимость (ДЕЛ)

Условие задания

Обозначим через m&n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14 & 5 = 11102 & 01012 = 01002 = 4. Для какого наименьшего неотрицательного целого числа А формула

(x & 25 ≠ 0) → ((x & 17 = 0) → (x & А ≠ 0))

тождественно истинна (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?
Ответ: 8

Общий шаблон задания №15 на Python

# === Задание 15: Истинность логического выражения (Отрезки / Множества) ===
for a in range(1, 1000):
    ok = True
    for x in range(1, 1000):
        # Подставьте формулу из условия:
        f = ((x % 3 == 0) <= (x % 5 != 0)) or (x + a >= 90)
        if not f:
            ok = False
            break
    if ok:
        print("Минимальное значение A:", a)
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №15.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.