Задание №13 ЕГЭ: Динамика и количество программ (ID 9188) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №13 Вариант ЕГЭ Разбор в СмартКИМ

Задание №13: Динамика и количество программ

Задача #9188 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №13:
Количество программ Обязательные и запрещённые этапы Динамика по состояниям

Условие задания

(Досрочный ЕГЭ-2026) У исполнителя имеются три команды, которые обозначены латинскими буквами:
A. Прибавить 1
B. Прибавить 3
C. Умножить на 2
Сколько существует программ, для которых при исходном числе 2 результатом является число 25, и при этом траектория вычислений содержит число 15 и не содержит 7?
Ответ: 2716

Решение на Python: Любой длины: обязательное 15, запрещённое 7

def count(start, end):
    ways = [0] * (end + 1)
    ways[start] = 1
    for v in range(start, end):
        if v == 7:
            ways[v] = 0
        ways[v + 1] += ways[v]
        if v + 3 <= end:
            ways[v + 3] += ways[v]
        if v * 2 <= end:
            ways[v * 2] += ways[v]
    return ways[end]


print(count(2, 15) * count(15, 25))

Этот код разобран по шагам в разборе задания №13: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.