Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 9036) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #9036 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(И. Карпачёв) У исполнителя имеются две команды, которые обозначены латинскими буквами:
A. Прибавь 6
B. Вычти 5
Первая команда увеличивает число на экране на 6. Вторая команда уменьшает число на экране на 5 (отрицательные числа допускаются). Сколько различных чисел можно получить из числа 10 с помощью программы, которая содержит ровно 12 команд, при условии, что траектория программы ни разу не проходит через число, содержащее цифру 7?
Ответ: 9

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.