Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8935) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8935 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

**(А. Сражаев) Напишите программу, которая перебирает целые числа, превышающие 2 480 000, которые единственным образом можно представить в виде суммы a3 + b5, где a и b – два различных натуральных числа, каждое из которых содержит цифру 9 в своей записи. В ответе запишите в первом столбце первые 5 найденных чисел в порядке возрастания, а во втором столбце — сумму чисел a и b.
Ответ: 2500488 48<br/>2535418 58<br/>2593748 68<br/>2681478 78<br/>2744668 148

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.