Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8867) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8867 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Р. Косов) Напишите программу, которая перебирает числа, большие 9 590 000, в порядке возрастания и находит первые 5 чисел, которые можно представить в виде произведения ровно семи различных простых сомножителей, среди которых ровно 2 содержат цифру 7. Запишите эти 5 чисел в порядке возрастания, справа от каждого числа запишите сумму его сомножителей, содержащих цифру 7.
Ответ: 9635010 104<br/>9658110 44<br/>9659910 64<br/>9662730 54<br/>9671970 86

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.