Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8865) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8865 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Р. Косов) Напишите программу, которая перебирает целые числа, меньшие 8 700 000, в порядке убывания и ищет среди них те, которые содержат цифру 1 или цифру 3, и при этом их можно представить в виде суммы четного натурального числа, являющегося полным квадратом, и натуральной степени числа 7. В ответе в первом столбце таблицы запишите первые 5 найденных чисел в порядке убывания, а во втором столбце для каждого числа – соответствующий показатель степени числа 7.
Ответ: 8697179 7<br/>8695723 5<br/>8693105 4<br/>8691047 3<br/>8690833 6

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.