Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8849) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8849 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Ю. Дрождинин) Напишите программу, которая перебирает целые числа, меньшие 987654321, в порядке убывания и ищет среди них такие, которые можно представить в виде произведения тринадцати не обязательно различных простых множителей, сумма которых содержит цифру 1. В ответе запишите в первой строке таблицы первые пять найденных чисел в порядке убывания, а во втором столбце – для каждого из них соответствующий наибольший из найденных множителей.
Ответ: 987654144 160751<br/>987650496 1601<br/>987648768 3323<br/>987644928 16921<br/>987640704 47

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.