Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8846) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8846 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(Ю. Дрождинин) Пусть S – сумма всех различных простых натуральных делителей целого числа, не считая самого числа. Если таких делителей у числа нет, то считаем значение S равным нулю. Напишите программу, которая перебирает целые числа, меньшие 7 612 000, в порядке убывания, и ищет среди них такие, для которых значение S больше 3 500 000 и оканчивается на 863. В ответе запишите первые пять найденных чисел в порядке возрастания, справа от каждого числа запишите соответствующее ему значение S.
Ответ: 7593722 3796863<br/>7601722 3800863<br/>7605722 3802863<br/>7607722 3803863<br/>7611722 3805863

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.