Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8841) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8841 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

Среди девятизначных натуральных чисел найдите пять наибольших чисел, которые можно представить в виде суммы некоторого натурального числа, кратного 1063, и суммы различных нетривиальных натуральных делителей этого числа. В ответе запишите все найденные числа в порядке возрастания, справа от каждого числа запишите сумму его нетривиальных делителей.
Ответ: 999988012 842095307<br/>999989301 333517002<br/>999991742 499995873<br/>999994149 910943450<br/>999997091 673980

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.