Задание №16 ЕГЭ: Вычисление рекурсивных функций (ID 8479) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №16 Вариант ЕГЭ Разбор в СмартКИМ

Задание №16: Вычисление рекурсивных функций

Задача #8479 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №16:
Рекурсивные соотношения с мемоизацией Глубокая рекурсия Сумма цифр и чётность

Условие задания

*Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:
F(n) = nn, если n > 450000;
F(n) = 3n + F(n + 14) + 2·F(n + 7), если n ≤ 450000.
Найдите последние 6 цифр значения F(73137).
Ответ: 785250

Общий шаблон задания №16 на Python

# === Задание 16: Рекурсивные функции (Мемоизация) ===
import sys
sys.setrecursionlimit(5000)

memo = {}
def f(n):
    if n in memo: return memo[n]
    if n <= 2: return 1
    if n % 2 == 0:
        res = 2 * n + f(n - 1)
    else:
        res = 3 * n**2 + f(n - 2)
    memo[n] = res
    return res

print("Результат:", f(2024) - f(2020))

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №16.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.