Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8406) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8406 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(А. Сражаев) Назовём особым числом такое простое натуральное число, которое на 150 больше ближайшего меньшего простого числа. Напишите программу, которая находит все особые числа на отрезке [10 000 000; 30 000 000]. В ответе запишите все найденные особые числа, справа от каждого из них запишите сумму всех делителей числа, полученного из найденного особого числа после удаления первой и последней цифр.
Ответ: 13626407 1124928<br/>17652163 2176902<br/>22790507 519126<br/>25180471 518048<br/>27980987 1383360

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.