Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8392) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8392 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(А. Сражаев) Напишите программу, которая перебирает целые числа, бóльшие 6 700 000, в порядке возрастания и ищет среди них такие, у которых есть ровно пять натуральных делителей, оканчивающихся на 29, либо на 51, либо на 78, и не равных ни самому числу, ни числу 29, ни числу 51, ни числу 78. В ответе запишите в первой строке таблицы первые пять найденных чисел в порядке возрастания, а во втором столбце – наибольший делитель для каждого из них.
Ответ: 6702696 3351348<br/>6703884 3351942<br/>6706602 3353301<br/>6707316 3353658<br/>6708174 3354087

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.