Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 8366) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #8366 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

*(А. Сражаев) Напишите программу, которая перебирает целые числа, большие 800 000, в порядке возрастания и ищет среди них последовательность чисел в которой у каждого числа последовательности одинаковое число делителей. В ответе в первом столбце таблицы запишите в порядке возрастания первые 5 подходящих чисел, образующие такую последовательность, а во втором столбце – соответствующий максимальный нетривиальный делитель (не совпадающий с самим числом) для каждого из чисел.
Ответ: 800002 400001<br/>800006 400003<br/>800009 114287<br/>800017 25807<br/>800022 400011

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.