Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 8198) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #8198 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(ЕГКР-2025) У исполнителя имеются три команды, которые обозначены латинскими буквами:
A. Прибавь 3
B. Прибавь 7
C. Умножь на 3
Программа для исполнителя – это последовательность команд. Сколько существует таких программ, которые исходное число 12 преобразуют в 89, и при этом траектория вычислений программы содержит числа 40 и 72 и не содержит 56?
Ответ: 324

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.