Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 8037) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #8037 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(О. Лысенков) На вход алгоритма подаётся неотрицательное число N. Алгоритм строит по нему новое число R следующим образом.
1) Строится 19-ричная запись числа N.
2) Полученная запись преобразуется по следующему алгоритму:
  а) если сумма значений цифр 19-ричной записи чётная, то последняя цифра перемещается в начало, а справа дописывается 1;
  б) если сумма значений цифр 19-ричной записи нечётная, то первая цифра перемещается в конец, а слева дописывается B.
Полученная таким образом запись является 19-ричной записью искомого числа R. Найдите количество чисел N, принадлежащих отрезку [1;10000], для которых результат работы алгоритма кратен либо 5, либо 3, но не обоим числам одновременно.
Ответ: 4002

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.