Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 8035) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #8035 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(О. Лысенков) На вход алгоритма подаётся неотрицательное число N. Алгоритм строит по нему новое число R следующим образом.
1) Строится 20-ричная запись числа N.
2) Каждая цифра этой записи увеличивается на 1, а если числовое значение цифры уже равно 19, то такая цифра заменяется на 0.
3) В начало числа записывается последняя цифра двоичной записи числа N.
4) Из записи удаляются незначащие нули.
Полученная таким образом запись является 20-ричной записью искомого числа R. Например, для исходного числа 265 = D520 результатом является число 1E620 = 686, а для исходного числа 66 = 3620 результатом является число 4720 = 87. Найдите наименьшее число N, такое что 20-ричная запись результата работы алгоритма R содержит не менее трёх разрядов и хотя бы два из них записываются латинскими буквами.
Ответ: 189

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.