Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 7962) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #7962 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Кабанов) Обозначим через D(N) наименьший простой делитель целого числа, оканчивающийся на 777 и не равный самому числу. Если таких делителей у числа нет, то считаем значение D(N) равным нулю. Найдите наименьшие 4 числа, большие 55 000 000, для которых D(N) > 0. В ответе запишите найденные числа в порядке возрастания значений D(N), справа от каждого запишите соответствующее значение D(N).
Ответ: 55001704 1777<br/>55001262 2777<br/>55000662 9166777<br/>55001554 27500777

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.