Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 7961) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #7961 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Кабанов) Обозначим через F(N) целую часть среднего арифметического всех простых делителей целого числа N, не считая самого числа. Если таких делителей у числа нет, то считаем значение F(N) равным нулю. Найдите первые 5 целых чисел, больших 9 500 000, для которых значение F(N) не равно нулю и кратно 813. В ответе запишите найденные числа в порядке возрастания значений F(N), справа от каждого запишите соответствующее значение F(N).
Ответ: 9500776 1626<br/>9504690 4878<br/>9506575 9756<br/>9506999 110568<br/>9503921 678855

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.