Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 7960) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #7960 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Кабанов) Обозначим через M(N) сумму максимального и минимального числа среди простых делителей целого числа N, не считая самого числа. Если таких делителей у числа нет, то считаем значение M(N) равным нулю. Найдите первые 6 чисел, больших 23 600 000, для которых значение M(N) при делении на 213 даёт в остатке 171. В ответе запишите найденные числа в порядке возрастания, справа от каждого запишите соответствующее значение M(N).
Ответ: 23600182 694125<br/>23600442 28713<br/>23600478 357585<br/>23600570 1449<br/>23600838 135639<br/>23600970 29139

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.