Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 7959) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #7959 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Кабанов) Обозначим через S(N) сумму простых делителей целого числа N, не считая самого числа. Если таких делителей у числа нет, то считаем значение S(N) равным нулю. Найдите первые 7 целых чисел, больших 32 500 000, для которых значение S(N) не равно нулю и кратно 145. В ответе запишите найденные числа в порядке возрастания, справа от каждого запишите соответствующее значение S(N).
Ответ: 32500280 2755<br/>32500301 58290<br/>32500440 1450<br/>32500623 17545<br/>32500665 722245<br/>32500700 7975<br/>32500834 4785

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.