Задание №17 ЕГЭ: Обработка целочисленных последовательностей (ID 7427) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №17 Вариант ЕГЭ Разбор в СмартКИМ

Задание №17: Обработка целочисленных последовательностей

Задача #7427 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №17:
Поиск пар элементов последовательности Тройки и кортежи чисел Фильтрация по делимости и остаткам

Условие задания

(А. Минак) В файле 17-400.txt содержится последовательность целых чисел. Все элементы последовательности различны и могут принимать целые значения от −100 000 до 100 000 включительно. Определите количество троек элементов последовательности, в которых ровно два числа оканчиваются цифрой 3 и хотя бы одно из чисел меньше минимального чётного элемента последовательности. В ответе запишите количество таких троек чисел, затем целую часть от среднего арифметического всех элементов последовательности, входящих в эти тройки. При вычислении среднего арифметического каждый элемент последовательности учитывается только один раз, даже если он входит в несколько подходящих троек. В данной задаче под тройкой подразумевается три подряд идущих элемента последовательности.
Ответ: 1771 6020

Общий шаблон задания №17 на Python

# === Задание 17: Обработка числовой последовательности ===
with open('17.txt') as f:
    a = [int(x) for x in f]

# Контрольное значение (например, макс. элемент, оканчивающийся на 13):
max_target = max(x for x in a if abs(x) % 100 == 13)

ans = []
for i in range(len(a) - 1):
    pair = (a[i], a[i+1])
    if sum(1 for x in pair if abs(x) % 100 == 13) == 1:
        if (pair[0]**2 + pair[1]**2) <= max_target**2:
            ans.append(pair[0] + pair[1])

print(f"Количество пар: {len(ans)}, Максимальная сумма: {max(ans)}")

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №17.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.