Задание №5 ЕГЭ: Анализ алгоритмов для исполнителей (ID 7406) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №5 Вариант ЕГЭ Разбор в СмартКИМ

Задание №5: Анализ алгоритмов для исполнителей

Задача #7406 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №5:
Двоичные автоматы Троичные и n-ичные автоматы Поиск минимального N или R

Условие задания

(А. Минак) На вход алгоритма подаётся натуральное число N > 143. Алгоритм строит по нему новое число R следующим образом.
1. Строится запись числа N в двенадцатеричной системе счисления.
2. Далее эта запись обрабатывается по следующему правилу:
  а) если N делится на 12, то в конец этой записи дописываются три её последние цифры;
  б) если число N на 12 не делится, то остаток от деления умножается на 3, переводится в двенадцатеричную запись и дописывается в начало числа.
Полученная таким образом запись является двенадцатеричной записью искомого числа R. Например, для исходного числа 204 = 15012 результатом является число 15015012 = 352716, а для исходного числа 275 = 1AB12 это число 291AB12 = 57299. Укажите такое число N, после обработки которого с помощью этого алгоритма получится наибольшее число R, которое меньше 58000.
Ответ: 971

Общий шаблон задания №5 на Python

# === Задание 5: Автомат преобразования двоичных чисел ===
for n in range(1, 1000):
    b = bin(n)[2:]
    if b.count('1') % 2 == 0:
        b = b + '0'
        b = '10' + b[2:]
    else:
        b = b + '1'
        b = '11' + b[2:]
    r = int(b, 2)
    if r > 40:
        print(f"Ответ: N={n}, R={r}")
        break

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №5.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.