Задание №17 ЕГЭ: Обработка целочисленных последовательностей (ID 6759) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №17 Вариант ЕГЭ Разбор в СмартКИМ

Задание №17: Обработка целочисленных последовательностей

Задача #6759 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №17:
Поиск пар элементов последовательности Тройки и кортежи чисел Фильтрация по делимости и остаткам

Условие задания

(ЕГЭ-2023) В файле 17-381.txt содержится последовательность целых чисел, не превышающих по модулю 100 000. Определите количество пар последовательности, в которых только один из элементов является четырёхзначным числом, а квадрат суммы элементов пары не больше квадрата максимального элемента последовательности, являющегося четырёхзначным числом и оканчивающегося на 39. В ответе запишите количество найденных пар чисел, затем максимальную из сумм элементов таких пар. В данной задаче под парой подразумевается два идущих подряд элемента последовательности.
Ответ: 1591 9233

Решение на Python: Боевой шаблон решения на Python

nums = [int(x) for x in open("17.txt")]

big = max(x for x in nums if len(str(abs(x))) == 4 and abs(x) % 100 == 39)

count = 0
best = -10 ** 9
for i in range(len(nums) - 1):
    a = nums[i]
    b = nums[i + 1]
    four_a = len(str(abs(a))) == 4
    four_b = len(str(abs(b))) == 4
    if four_a != four_b and (a + b) ** 2 <= big ** 2:
        count += 1
        best = max(best, a + b)

print(count, best)

Этот код разобран по шагам в разборе задания №17: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.