Задание №24 ЕГЭ: Обработка символьных строк (ID 6675) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №24 Вариант ЕГЭ Разбор в СмартКИМ

Задание №24: Обработка символьных строк

Задача #6675 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №24:
Цепочки символов фиксированного типа Замена запрещённых пар Чередующиеся гласные и согласные

Условие задания

(ЕГЭ-2023) Текстовый файл 24-263.txt состоит не более чем из 106 символов и содержит только заглавные буквы латинского алфавита. Определите максимальную длину подстроки, в которой символ Y встречается не более 150 раз.
Ответ: 5195

Решение на Python: Боевой шаблон решения на Python

s = open("24.txt").readline().strip()

k = 150
parts = s.split("Y")
best = 0
for i in range(len(parts) - k):
    length = k
    for j in range(i, i + k + 1):
        length += len(parts[j])
    best = max(best, length)

print(best)

Этот код разобран по шагам в разборе задания №24: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.