Задание №23 ЕГЭ: Динамическое программирование (Количество программ) (ID 6612) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №23 Вариант ЕГЭ Разбор в СмартКИМ

Задание №23: Динамическое программирование (Количество программ)

Задача #6612 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №23:
Количество программ преобразования чисел Обязательные и избегаемые этапы траектории

Условие задания

(И. Карпачев) У исполнителя Калькулятор имеются три команды, которым присвоены номера:
1. Вычти 5
2. Прибавь 2
3. Возведи в квадрат
Выполняя первую из них, исполнитель уменьшает число на экране на 5, выполняя вторую – увеличивает на 2, выполняя третью – возводит число в квадрат. Исполнитель работает только с натуральными числами. Программой для исполнителя называется последовательность команд. Сколько существует программ, состоящих ровно из 7 команд, для которых при исходном числе 3 результатом является число 28?
Ответ: 11

Шаблон решения на Python

# === Задание 23: Динамическое программирование (Количество программ) ===
def f(cur, target, avoid=None):
    if cur > target or (avoid and cur == avoid): return 0
    if cur == target: return 1
    return f(cur + 1, target, avoid) + f(cur * 2, target, avoid)

# Траектория из A в B (через обязательную точку):
print("Количество программ:", f(2, 12) * f(12, 30))

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.