Задание №25 ЕГЭ: Обработка целочисленной информации и маски (ID 6516) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №25 Вариант ЕГЭ Разбор в СмартКИМ

Задание №25: Обработка целочисленной информации и маски

Задача #6516 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №25:
Маски чисел (* и ?) Делители натуральных чисел Поиск чисел с особыми свойствами делителей

Условие задания

(А. Богданов) Назовём маской числа последовательность цифр, в которой может встречаться символ «#», означающий любое число, которое делится без остатка на куб суммы своих цифр. Среди натуральных чисел, не превышающих 1010, найдите все числа, соответствующие маске 1234#, делящиеся на 137 без остатка. В ответе запишите все найденные числа в порядке возрастания, справа от каждого числа – частное от его деления на 137.
Ответ: 12340001 90073<br/>123400010 900730<br/>123437000 901000<br/>1234000100 9007300<br/>1234370000 9010000

Общий шаблон задания №25 на Python

# === Задание 25: Маски чисел и делители ===
from fnmatch import fnmatch

ans = []
for n in range(10**7, 10**8):
    if fnmatch(str(n), "12*34?5"):
        if n % 2024 == 0:
            print(n, n // 2024)

Шаблон общий для всего номера: формулу, числа и строки подставьте из условия. Как это делать, показано в разборе задания №25.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.