Задание №16 ЕГЭ: Вычисление рекурсивных функций (ID 6485) — Ответ, условие и разбор | СмартКИМ
Не нашли свое задание? Попробуйте КИМСканер для быстрого поиска решения по фото или тексту: Открыть КИМСканер
СмартКИМ ЕГЭ Информатика
Каталог №16 Вариант ЕГЭ Разбор в СмартКИМ

Задание №16: Вычисление рекурсивных функций

Задача #6485 Формат ЕГЭ 2026 1 первичный балл
Основные типы и прототипы задания №16:
Рекурсивные соотношения с мемоизацией Глубокая рекурсия Сумма цифр и чётность

Условие задания

Алгоритм вычисления функций F(n) и G(n), где n – натуральное число, задан следующими соотношениями:
F(n) = n, если n > 1000000;
F(n) = 3n + F(5n), если n ≤ 1000000.
G(n) = F(n) / n.
Определите количество натуральных чисел n (включая n = 3000), для которых G(n) = G(3000).
Ответ: 6400

Решение на Python: Считаем числа с тем же числом шагов

n = 3000
steps_3000 = 0
while n <= 1000000:
    n = n * 5
    steps_3000 += 1

count = 0
for start in range(1, 1000001):
    n = start
    steps = 0
    while n <= 1000000:
        n = n * 5
        steps += 1
    if steps == steps_3000:
        count += 1

print(count)

Этот код разобран по шагам в разборе задания №16: там же типичные ошибки и лайфхаки.

Подготовка к ЕГЭ по информатике на 85+ баллов

В интерактивном тренажёре СмартКИМ вы можете решать варианты на время, писать и запускать код Python в браузере, работать с таблицами Excel и отслеживать свой классный рейтинг.